summaryrefslogtreecommitdiffstats
path: root/packaging/macos/modulesets/patches/gspell-makefile_objc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/macos/modulesets/patches/gspell-makefile_objc.patch')
-rw-r--r--packaging/macos/modulesets/patches/gspell-makefile_objc.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/packaging/macos/modulesets/patches/gspell-makefile_objc.patch b/packaging/macos/modulesets/patches/gspell-makefile_objc.patch
new file mode 100644
index 0000000..e9a7e65
--- /dev/null
+++ b/packaging/macos/modulesets/patches/gspell-makefile_objc.patch
@@ -0,0 +1,20 @@
+Patch taken from homebrew formula.
+Removed gtk-mac-integration dependency.
+https://github.com/Homebrew/homebrew-core/blob/cd1e31a/Formula/gspell.rb
+diff --git a/gspell/Makefile.am b/gspell/Makefile.am
+index 076a9fd..6c67184 100644
+--- a/gspell/Makefile.am
++++ b/gspell/Makefile.am
+@@ -155,6 +156,12 @@ gspell_private_headers += \
+ gspell_private_c_files += \
+ gspell-osx.c
+
++libgspell_core_la_CFLAGS += \
++ -xobjective-c
++
++libgspell_core_la_LDFLAGS += \
++ -framework Cocoa
++
+ endif # OS_OSX
+
+ if HAVE_INTROSPECTION