summaryrefslogtreecommitdiffstats
path: root/share/icons/application/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'share/icons/application/CMakeLists.txt')
-rw-r--r--share/icons/application/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/share/icons/application/CMakeLists.txt b/share/icons/application/CMakeLists.txt
new file mode 100644
index 0000000..7faf431
--- /dev/null
+++ b/share/icons/application/CMakeLists.txt
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+# install application icons into system-wide hicolor icon theme "apps" folder
+# it's also the fallback for all other themes that do not include a customized Inkscape icon.
+set(PIXMAP_SIZES "16x16" "22x22" "24x24" "32x32" "48x48" "256x256" "scalable" "symbolic")
+foreach(pixmap_size ${PIXMAP_SIZES})
+ FILE(GLOB PIXMAP_FILES ${CMAKE_CURRENT_SOURCE_DIR}/${pixmap_size}/*.png ${CMAKE_CURRENT_SOURCE_DIR}/${pixmap_size}/*.svg)
+ install(FILES ${PIXMAP_FILES} DESTINATION ${SHARE_INSTALL}/icons/hicolor/${pixmap_size}/apps)
+endforeach(pixmap_size)