summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/2geom/RELEASING.md
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/2geom/RELEASING.md')
-rw-r--r--src/3rdparty/2geom/RELEASING.md21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/3rdparty/2geom/RELEASING.md b/src/3rdparty/2geom/RELEASING.md
new file mode 100644
index 0000000..33a9b24
--- /dev/null
+++ b/src/3rdparty/2geom/RELEASING.md
@@ -0,0 +1,21 @@
+# REALISING
+Add a release note to `NEWS.md`.
+
+Set `2GEOM_MAJOR_VERSION`, `2GEOM_MINOR_VERSION`, and `2GEOM_PATCH_VERSION` in
+*CMakeLists.txt*.
+
+```bash
+cmake .
+make
+make test
+make dist
+```
+
+Next, copy `lib2geom-${VERSION}.tar.bz2` to `/tmp/``, extract it, and verify
+it builds.
+
+```bash
+gpg --armor --detach-sign --output lib2geom-${VERSION}.tar.bz2.sig lib2geom-${VERSION}.tar.bz2
+git tag -s ${MAJOR}.${MINOR}
+git push --tags
+```