summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/2geom/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/2geom/src/CMakeLists.txt')
-rw-r--r--src/3rdparty/2geom/src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/3rdparty/2geom/src/CMakeLists.txt b/src/3rdparty/2geom/src/CMakeLists.txt
new file mode 100644
index 0000000..268d4df
--- /dev/null
+++ b/src/3rdparty/2geom/src/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_subdirectory(2geom)
+add_subdirectory(performance-tests EXCLUDE_FROM_ALL)
+if(GTK3_FOUND)
+ add_subdirectory(toys EXCLUDE_FROM_ALL)
+else()
+ message("Not building toys as they require GTK3.")
+endif()
+
+add_subdirectory(cython EXCLUDE_FROM_ALL)
+add_subdirectory(py2geom EXCLUDE_FROM_ALL)