summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/adaptagrams/libcola/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/adaptagrams/libcola/CMakeLists.txt')
-rw-r--r--src/3rdparty/adaptagrams/libcola/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/3rdparty/adaptagrams/libcola/CMakeLists.txt b/src/3rdparty/adaptagrams/libcola/CMakeLists.txt
new file mode 100644
index 0000000..59bbacc
--- /dev/null
+++ b/src/3rdparty/adaptagrams/libcola/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+set(libcola_SRC
+ box.cpp
+ cluster.cpp
+ cola.cpp
+ convex_hull.cpp
+ compound_constraints.cpp
+ conjugate_gradient.cpp
+ connected_components.cpp
+ gradient_projection.cpp
+ shapepair.cpp
+ straightener.cpp
+
+
+ # -------
+ # Headers
+ box.h
+ cluster.h
+ cola.h
+ compound_constraints.h
+ conjugate_gradient.h
+ convex_hull.h
+ gradient_projection.h
+ shapepair.cpp
+ shortest_paths.h
+ straightener.h
+)
+
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}/..")
+add_inkscape_lib(cola_LIB "${libcola_SRC}")