summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt')
-rw-r--r--src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt b/src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt
new file mode 100644
index 0000000..538ad30
--- /dev/null
+++ b/src/3rdparty/adaptagrams/libvpsc/CMakeLists.txt
@@ -0,0 +1,28 @@
+
+set(libvpsc_SRC
+ block.cpp
+ blocks.cpp
+ cbuffer.cpp
+ constraint.cpp
+ rectangle.cpp
+ solve_VPSC.cpp
+ variable.cpp
+
+
+ # -------
+ # Headers
+ assertions.h
+ block.h
+ blocks.h
+ cbuffer.h
+ constraint.h
+ exceptions.h
+ linesegment.h
+ pairing_heap.h
+ rectangle.h
+ solve_VPSC.h
+ variable.h
+)
+
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}/..")
+add_inkscape_lib(vpsc_LIB "${libvpsc_SRC}")