summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am')
-rw-r--r--src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am b/src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am
new file mode 100644
index 0000000..d155c52
--- /dev/null
+++ b/src/3rdparty/adaptagrams/libvpsc/tests/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -I$(top_srcdir)
+
+check_PROGRAMS = rectangleoverlap block satisfy_inc # cycle
+satisfy_inc_SOURCES = satisfy_inc.cpp
+satisfy_inc_LDADD = $(top_builddir)/libvpsc/libvpsc.la # -L$(mosek_home)/bin -lmosek -lguide -limf -lirc
+block_SOURCES = block.cpp
+block_LDADD = $(top_builddir)/libvpsc/libvpsc.la
+rectangleoverlap_SOURCES = rectangleoverlap.cpp
+rectangleoverlap_LDADD = $(top_builddir)/libvpsc/libvpsc.la
+
+#cycle_SOURCES = cycle.cpp
+#cycle_LDADD = $(top_builddir)/libvpsc/libvpsc.la
+
+TESTS = $(check_PROGRAMS)
+