summaryrefslogtreecommitdiffstats
path: root/src/helper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/helper/CMakeLists.txt')
-rw-r--r--src/helper/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/helper/CMakeLists.txt b/src/helper/CMakeLists.txt
new file mode 100644
index 0000000..18baf7b
--- /dev/null
+++ b/src/helper/CMakeLists.txt
@@ -0,0 +1,46 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+include(${CMAKE_SOURCE_DIR}/CMakeScripts/UseGlibMarshal.cmake)
+
+GLIB_MARSHAL(sp_marshal sp-marshal "${CMAKE_CURRENT_BINARY_DIR}/helper")
+
+set(sp_marshal_SRC
+ ${CMAKE_CURRENT_BINARY_DIR}/sp-marshal.cpp
+ ${CMAKE_CURRENT_BINARY_DIR}/sp-marshal.h
+)
+
+set(helper_SRC
+ geom.cpp
+ geom-nodetype.cpp
+ geom-pathstroke.cpp
+ geom-pathvector_nodesatellites.cpp
+ geom-nodesatellite.cpp
+ gettext.cpp
+ pixbuf-ops.cpp
+ png-write.cpp
+ stock-items.cpp
+ #units-test.cpp
+
+ # we generate this file and it's .h counter-part
+ ${sp_marshal_SRC}
+
+
+ # -------
+ # Headers
+ geom-curves.h
+ geom-nodetype.h
+ geom-pathstroke.h
+ geom-pathvector_nodesatellites.h
+ geom-nodesatellite.h
+ geom.h
+ gettext.h
+ mathfns.h
+ pixbuf-ops.h
+ png-write.h
+ stock-items.h
+)
+
+set_source_files_properties(sp_marshal_SRC PROPERTIES GENERATED true)
+
+# add_inkscape_lib(helper_LIB "${helper_SRC}")
+add_inkscape_source("${helper_SRC}")