summaryrefslogtreecommitdiffstats
path: root/src/io/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/io/CMakeLists.txt')
-rw-r--r--src/io/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/io/CMakeLists.txt b/src/io/CMakeLists.txt
new file mode 100644
index 0000000..2d5198c
--- /dev/null
+++ b/src/io/CMakeLists.txt
@@ -0,0 +1,36 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(io_SRC
+ dir-util.cpp
+ file.cpp
+ file-export-cmd.cpp
+ resource.cpp
+ fix-broken-links.cpp
+ stream/bufferstream.cpp
+ stream/gzipstream.cpp
+ stream/inkscapestream.cpp
+ stream/stringstream.cpp
+ stream/uristream.cpp
+ stream/xsltstream.cpp
+ sys.cpp
+ http.cpp
+
+ # -------
+ # Headers
+ dir-util.h
+ file.h
+ file-export-cmd.h
+ resource.h
+ fix-broken-links.h
+ stream/bufferstream.h
+ stream/gzipstream.h
+ stream/inkscapestream.h
+ stream/stringstream.h
+ stream/uristream.h
+ stream/xsltstream.h
+ sys.h
+ http.h
+)
+
+# add_inkscape_lib(io_LIB "${io_SRC}")
+add_inkscape_source("${io_SRC}")