summaryrefslogtreecommitdiffstats
path: root/src/livarot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/livarot/CMakeLists.txt')
-rw-r--r--src/livarot/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/livarot/CMakeLists.txt b/src/livarot/CMakeLists.txt
new file mode 100644
index 0000000..398f7a2
--- /dev/null
+++ b/src/livarot/CMakeLists.txt
@@ -0,0 +1,44 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(livarot_SRC
+ AlphaLigne.cpp
+ AVL.cpp
+ BitLigne.cpp
+ float-line.cpp
+ int-line.cpp
+ PathConversion.cpp
+ Path.cpp
+ PathCutting.cpp
+ path-description.cpp
+ PathOutline.cpp
+ PathSimplify.cpp
+ PathStroke.cpp
+ Shape.cpp
+ ShapeDraw.cpp
+ ShapeMisc.cpp
+ ShapeRaster.cpp
+ ShapeSweep.cpp
+ sweep-event.cpp
+ sweep-tree.cpp
+ sweep-tree-list.cpp
+
+
+ # -------
+ # Headers
+ AVL.h
+ AlphaLigne.h
+ BitLigne.h
+ LivarotDefs.h
+ Path.h
+ Shape.h
+ float-line.h
+ int-line.h
+ path-description.h
+ sweep-event-queue.h
+ sweep-event.h
+ sweep-tree-list.h
+ sweep-tree.h
+)
+
+add_inkscape_lib(livarot_LIB "${livarot_SRC}")
+target_link_libraries(livarot_LIB PUBLIC 2Geom::2geom) \ No newline at end of file