summaryrefslogtreecommitdiffstats
path: root/src/svg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/svg/CMakeLists.txt')
-rw-r--r--src/svg/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/svg/CMakeLists.txt b/src/svg/CMakeLists.txt
new file mode 100644
index 0000000..0abb9cd
--- /dev/null
+++ b/src/svg/CMakeLists.txt
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(svg_SRC
+ css-ostringstream.cpp
+ path-string.cpp
+ # sp-svg.def
+ stringstream.cpp
+ strip-trailing-zeros.cpp
+ svg-affine.cpp
+ svg-affine-parser.cpp
+ svg-color.cpp
+ svg-angle.cpp
+ svg-length.cpp
+ svg-bool.cpp
+ svg-path.cpp
+
+
+ # -------
+ # Headers
+ css-ostringstream.h
+ path-string.h
+ stringstream.h
+ strip-trailing-zeros.h
+ svg-color.h
+ svg-icc-color.h
+ svg-angle.h
+ svg-length.h
+ svg-bool.h
+ svg.h
+
+)
+
+# add_inkscape_lib(svg_LIB "${svg_SRC}")
+add_inkscape_source("${svg_SRC}")