summaryrefslogtreecommitdiffstats
path: root/src/trace/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/trace/CMakeLists.txt')
-rw-r--r--src/trace/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/trace/CMakeLists.txt b/src/trace/CMakeLists.txt
new file mode 100644
index 0000000..45b3125
--- /dev/null
+++ b/src/trace/CMakeLists.txt
@@ -0,0 +1,31 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+set(trace_SRC
+ filterset.cpp
+ imagemap.cpp
+ imagemap-gdk.cpp
+ quantize.cpp
+ siox.cpp
+ trace.cpp
+
+ potrace/inkscape-potrace.cpp
+ autotrace/inkscape-autotrace.cpp
+ depixelize/inkscape-depixelize.cpp
+
+ # -------
+ # Headers
+ filterset.h
+ imagemap-gdk.h
+ imagemap.h
+ pool.h
+ quantize.h
+ siox.h
+ trace.h
+
+ potrace/bitmap.h
+ potrace/inkscape-potrace.h
+ autotrace/inkscape-autotrace.h
+ depixelize/inkscape-depixelize.h
+)
+
+add_inkscape_source("${trace_SRC}")
+