summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
new file mode 100644
index 0000000..0855b5a
--- /dev/null
+++ b/src/widgets/CMakeLists.txt
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(widgets_SRC
+ desktop-widget.cpp
+ ege-paint-def.cpp
+ sp-attribute-widget.cpp
+ sp-xmlview-tree.cpp
+ spw-utilities.cpp
+ toolbox.cpp
+
+ # -------
+ # Headers
+ desktop-widget.h
+ ege-paint-def.h
+ sp-attribute-widget.h
+ sp-xmlview-tree.h
+ spw-utilities.h
+ toolbox.h
+ widget-sizes.h
+)
+
+add_inkscape_source("${widgets_SRC}")