summaryrefslogtreecommitdiffstats
path: root/tests/integration/deckard/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
commit830407e88f9d40d954356c3754f2647f91d5c06a (patch)
treed6a0ece6feea91f3c656166dbaa884ef8a29740e /tests/integration/deckard/setup.py
parentInitial commit. (diff)
downloadknot-resolver-upstream.tar.xz
knot-resolver-upstream.zip
Adding upstream version 5.6.0.upstream/5.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/integration/deckard/setup.py')
-rw-r--r--tests/integration/deckard/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/integration/deckard/setup.py b/tests/integration/deckard/setup.py
new file mode 100644
index 0000000..93e22b7
--- /dev/null
+++ b/tests/integration/deckard/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python3
+from distutils.core import setup
+
+version = '3.0'
+
+setup(
+ name='deckard',
+ version=version,
+ description='DNS toolkit',
+ long_description=(
+ "Deckard is a DNS software testing based on library pydnstest."
+ "It supports parsing and running Unbound-like test scenarios,"
+ "and setting up a mock DNS server. It's based on dnspython."),
+ author='CZ.NIC',
+ author_email='knot-dns-users@lists.nic.cz',
+ license='BSD',
+ url='https://gitlab.nic.cz/knot/deckard',
+ packages=['pydnstest'],
+ python_requires='>=3.5',
+ install_requires=[
+ 'dnspython>=1.15',
+ 'jinja2',
+ 'PyYAML',
+ 'python-augeas'
+ ],
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python :: 3 :: Only'
+ 'Operating System :: POSIX :: Linux',
+ 'Topic :: Internet :: Name Service (DNS)',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Software Development :: Quality Assurance',
+ 'Topic :: Software Development :: Testing',
+ ]
+)