summaryrefslogtreecommitdiffstats
path: root/utils/client/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:26:00 +0000
commit830407e88f9d40d954356c3754f2647f91d5c06a (patch)
treed6a0ece6feea91f3c656166dbaa884ef8a29740e /utils/client/meson.build
parentInitial commit. (diff)
downloadknot-resolver-830407e88f9d40d954356c3754f2647f91d5c06a.tar.xz
knot-resolver-830407e88f9d40d954356c3754f2647f91d5c06a.zip
Adding upstream version 5.6.0.upstream/5.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'utils/client/meson.build')
-rw-r--r--utils/client/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/utils/client/meson.build b/utils/client/meson.build
new file mode 100644
index 0000000..761c2cd
--- /dev/null
+++ b/utils/client/meson.build
@@ -0,0 +1,37 @@
+# client
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+kresc_src = files([
+ 'kresc.c',
+])
+c_src_lint += kresc_src
+
+build_client = false
+if get_option('client') != 'disabled'
+ message('--- client dependencies ---')
+ libedit = dependency('libedit', required: false)
+ if libedit.found()
+ build_client = true
+ else # darwin workaround: missing pkgconfig
+ libedit = meson.get_compiler('c').find_library(
+ 'edit', required: get_option('client') == 'enabled')
+ if libedit.found()
+ build_client = true
+ endif
+ endif
+ message('---------------------------')
+endif
+
+
+if build_client
+ kresc = executable(
+ 'kresc',
+ kresc_src,
+ dependencies: [
+ contrib_dep,
+ libedit,
+ ],
+ install: true,
+ install_dir: get_option('sbindir'),
+ )
+endif