summaryrefslogtreecommitdiffstats
path: root/distro/pkg/nix/top-level.nix
diff options
context:
space:
mode:
Diffstat (limited to 'distro/pkg/nix/top-level.nix')
-rw-r--r--distro/pkg/nix/top-level.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/distro/pkg/nix/top-level.nix b/distro/pkg/nix/top-level.nix
new file mode 100644
index 0000000..bdd3360
--- /dev/null
+++ b/distro/pkg/nix/top-level.nix
@@ -0,0 +1,12 @@
+with import <nixpkgs> {};
+
+(callPackage ./. {
+}).overrideAttrs (attrs: {
+ src = ./knot-resolver-{{ version }}.tar.xz;
+
+ # This just breaks in our GitLab CI (not locally and not on hydra.nixos.org)
+ installCheckPhase = ''
+ meson test --print-errorlogs --no-suite snowflake
+ '';
+})
+