summaryrefslogtreecommitdiffstats
path: root/modules/hints/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hints/meson.build')
-rw-r--r--modules/hints/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/hints/meson.build b/modules/hints/meson.build
new file mode 100644
index 0000000..0a0945c
--- /dev/null
+++ b/modules/hints/meson.build
@@ -0,0 +1,24 @@
+# C module: hints
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+hints_src = files([
+ 'hints.c',
+])
+c_src_lint += hints_src
+
+hints_mod = shared_module(
+ 'hints',
+ hints_src,
+ dependencies: [
+ libknot,
+ luajit_inc,
+ ],
+ include_directories: mod_inc_dir,
+ name_prefix: '',
+ install: true,
+ install_dir: modules_dir,
+)
+
+config_tests += [
+ ['hints', files('tests/hints.test.lua'), ['skip_asan']],
+]