summaryrefslogtreecommitdiffstats
path: root/RepositoryModule_build.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /RepositoryModule_build.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'RepositoryModule_build.mk')
-rw-r--r--RepositoryModule_build.mk95
1 files changed, 95 insertions, 0 deletions
diff --git a/RepositoryModule_build.mk b/RepositoryModule_build.mk
new file mode 100644
index 000000000..de906d605
--- /dev/null
+++ b/RepositoryModule_build.mk
@@ -0,0 +1,95 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cross_toolset))
+
+$(eval $(call gb_Module_add_moduledirs,cross_toolset,\
+ basegfx \
+ binaryurp \
+ bridges \
+ cli_ure \
+ codemaker \
+ comphelper \
+ cppu \
+ cppuhelper \
+ external \
+ i18nlangtag \
+ i18nutil \
+ i18npool \
+ instsetoo_native \
+ idl \
+ io \
+ javaunohelper \
+ jurt \
+ jvmaccess \
+ jvmfwk \
+ l10ntools \
+ o3tl \
+ offapi \
+ officecfg \
+ oovbaapi \
+ pch \
+ registry \
+ remotebridges \
+ ridljar \
+ sal \
+ salhelper \
+ sax \
+ setup_native \
+ shell \
+ solenv \
+ soltools \
+ stoc \
+ store \
+ tools \
+ ucbhelper \
+ udkapi \
+ unoidl \
+ unoil \
+ unotest \
+ unotools \
+ ure \
+ xmlreader \
+ $(if $(WITH_GALLERY_BUILD), \
+ avmedia \
+ basic \
+ canvas \
+ configmgr \
+ connectivity \
+ cppcanvas \
+ drawinglayer \
+ editeng \
+ emfio \
+ filter \
+ framework \
+ linguistic \
+ officecfg \
+ package \
+ postprocess \
+ sfx2 \
+ shell \
+ sot \
+ svgio \
+ svl \
+ svtools \
+ svx \
+ toolkit \
+ ucb \
+ unoxml \
+ uui \
+ vcl \
+ xmloff \
+ xmlscript \
+ ) \
+ $(call gb_Helper_optionals_or,HELPTOOLS XMLHELP,helpcompiler) \
+ $(call gb_Helper_optional,XMLHELP,xmlhelp) \
+ $(call gb_Helper_optional,QADEVOOO,qadevOOo) \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: