summaryrefslogtreecommitdiffstats
path: root/UnoControls/Library_ctl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /UnoControls/Library_ctl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'UnoControls/Library_ctl.mk')
-rw-r--r--UnoControls/Library_ctl.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/UnoControls/Library_ctl.mk b/UnoControls/Library_ctl.mk
new file mode 100644
index 000000000..e123a4a59
--- /dev/null
+++ b/UnoControls/Library_ctl.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,ctl))
+
+$(eval $(call gb_Library_set_include,ctl,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/UnoControls/inc \
+ -I$(SRCDIR)/UnoControls/source/inc \
+))
+
+$(eval $(call gb_Library_use_sdk_api,ctl))
+
+$(eval $(call gb_Library_use_libraries,ctl,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+))
+
+$(eval $(call gb_Library_set_componentfile,ctl,UnoControls/util/ctl,services))
+
+$(eval $(call gb_Library_add_exception_objects,ctl,\
+ UnoControls/source/base/basecontainercontrol \
+ UnoControls/source/base/basecontrol \
+ UnoControls/source/base/multiplexer \
+ UnoControls/source/controls/OConnectionPointContainerHelper \
+ UnoControls/source/controls/OConnectionPointHelper \
+ UnoControls/source/controls/framecontrol \
+ UnoControls/source/controls/progressbar \
+ UnoControls/source/controls/progressmonitor \
+ UnoControls/source/controls/statusindicator \
+))
+
+# vim:set noet sw=4 ts=4: