summaryrefslogtreecommitdiffstats
path: root/android/CustomTarget_lo_android.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /android/CustomTarget_lo_android.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'android/CustomTarget_lo_android.mk')
-rw-r--r--android/CustomTarget_lo_android.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/android/CustomTarget_lo_android.mk b/android/CustomTarget_lo_android.mk
new file mode 100644
index 000000000..93a434d11
--- /dev/null
+++ b/android/CustomTarget_lo_android.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+$(eval $(call gb_CustomTarget_CustomTarget,android/loandroid3))
+
+loandroid3_DIR := $(call gb_CustomTarget_get_workdir,android/source)
+
+$(call gb_CustomTarget_get_target,android/loandroid3) : \
+ $(loandroid3_DIR)/done
+
+$(loandroid3_DIR)/done : $(call gb_Postprocess_get_target,AllModulesButInstsetNative)
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),MAK,2)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),MAK)
+ cd $(SRCDIR)/android/source && $(MAKE) all
+ifeq ($(ENABLE_JAVA),TRUE)
+# Copy to $(BUILDDIR)/instsetoo_native as that is where the tinderbox build script
+# still looks for the .apk, and we want fresh daily builds to be uploaded.
+# Us "foo" instead of the old INPATH
+ mkdir -p $(BUILDDIR)/instsetoo_native/foo/bin; \
+ if test "$$ENABLE_ANDROID_LOK" != "TRUE" ; then cp $(SRCDIR)/android/source/build/outputs/apk/strippedUI$(if $(ENABLE_ANDROID_EDITING),Editing)/$(if $(ENABLE_RELEASE_BUILD),release/*-release-unsigned.apk,debug/*-debug.apk) $(BUILDDIR)/instsetoo_native/foo/bin ; fi
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),MAK)
+endif
+
+$(call gb_CustomTarget_get_clean_target,android/loandroid3) :
+ $(call gb_Output_announce,$(subst $(WORKDIR)/Clean/,,$@),$(false),MAK,2)
+ cd $(SRCDIR)/android/source && $(MAKE) clean
+
+# vim: set noet sw=4 ts=4: