summaryrefslogtreecommitdiffstats
path: root/apple_remote/Library_AppleRemote.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /apple_remote/Library_AppleRemote.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'apple_remote/Library_AppleRemote.mk')
-rw-r--r--apple_remote/Library_AppleRemote.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/apple_remote/Library_AppleRemote.mk b/apple_remote/Library_AppleRemote.mk
new file mode 100644
index 000000000..cf485533c
--- /dev/null
+++ b/apple_remote/Library_AppleRemote.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,AppleRemote))
+
+$(eval $(call gb_Library_use_system_darwin_frameworks,AppleRemote,\
+ Cocoa \
+ Carbon \
+ IOKit \
+))
+
+$(eval $(call gb_Library_add_objcobjects,AppleRemote,\
+ apple_remote/source/KeyspanFrontRowControl \
+ apple_remote/source/AppleRemote \
+ apple_remote/source/RemoteControl \
+ apple_remote/source/RemoteControlContainer \
+ apple_remote/source/GlobalKeyboardDevice \
+ apple_remote/source/HIDRemoteControlDevice \
+ apple_remote/source/MultiClickRemoteBehavior \
+ apple_remote/source/RemoteMainController \
+))
+
+# vim: set noet sw=4 ts=4: