summaryrefslogtreecommitdiffstats
path: root/basegfx/CppunitTest_basegfx.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /basegfx/CppunitTest_basegfx.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'basegfx/CppunitTest_basegfx.mk')
-rw-r--r--basegfx/CppunitTest_basegfx.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/basegfx/CppunitTest_basegfx.mk b/basegfx/CppunitTest_basegfx.mk
new file mode 100644
index 000000000..88f496626
--- /dev/null
+++ b/basegfx/CppunitTest_basegfx.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,basegfx))
+
+$(eval $(call gb_CppunitTest_use_external,basegfx,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,basegfx))
+
+$(eval $(call gb_CppunitTest_use_libraries,basegfx,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,basegfx,\
+ basegfx/test/B2DRangeTest \
+ basegfx/test/B2IRangeTest \
+ basegfx/test/B2DPolyRangeTest \
+ basegfx/test/B2DHomMatrixTest \
+ basegfx/test/B2DPointTest \
+ basegfx/test/B2DPolygonTest \
+ basegfx/test/B2DPolygonToolsTest \
+ basegfx/test/B2DPolyPolygonTest \
+ basegfx/test/B2DPolyPolygonCutterTest \
+ basegfx/test/B1DRangeTest \
+ basegfx/test/B2XRangeTest \
+ basegfx/test/B2IBoxTest \
+ basegfx/test/B2DTupleTest \
+ basegfx/test/B3DTupleTest \
+ basegfx/test/BColorModifierTest \
+ basegfx/test/BColorTest \
+ basegfx/test/SvgPathImportExport \
+ basegfx/test/basegfx3d \
+ basegfx/test/boxclipper \
+ basegfx/test/basegfxtools \
+ basegfx/test/clipstate \
+ basegfx/test/genericclipper \
+ basegfx/test/VectorTest \
+))
+
+# vim: set noet sw=4 ts=4: