summaryrefslogtreecommitdiffstats
path: root/bean/Module_bean.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /bean/Module_bean.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bean/Module_bean.mk')
-rw-r--r--bean/Module_bean.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/bean/Module_bean.mk b/bean/Module_bean.mk
new file mode 100644
index 000000000..08d939076
--- /dev/null
+++ b/bean/Module_bean.mk
@@ -0,0 +1,29 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Module_Module,bean))
+
+ifneq ($(ENABLE_JAVA),)
+
+ifneq ($(OS),MACOSX)
+ifneq ($(OS),ANDROID)
+$(eval $(call gb_Module_add_targets,bean,\
+ Jar_officebean \
+ Library_officebean \
+))
+
+# complex tests compilable but fail at runtime
+#$(eval $(call gb_Module_add_subsequentcheck_targets,bean,\
+# JunitTest_bean_complex \
+#))
+endif
+endif
+
+endif