summaryrefslogtreecommitdiffstats
path: root/binaryurp/CppunitTest_binaryurp_test-cache.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /binaryurp/CppunitTest_binaryurp_test-cache.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'binaryurp/CppunitTest_binaryurp_test-cache.mk')
-rw-r--r--binaryurp/CppunitTest_binaryurp_test-cache.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/binaryurp/CppunitTest_binaryurp_test-cache.mk b/binaryurp/CppunitTest_binaryurp_test-cache.mk
new file mode 100644
index 000000000..97f5b78f0
--- /dev/null
+++ b/binaryurp/CppunitTest_binaryurp_test-cache.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,binaryurp_test-cache))
+
+$(eval $(call gb_CppunitTest_use_external,binaryurp_test-cache,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,binaryurp_test-cache,\
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,binaryurp_test-cache,\
+ binaryurp/qa/test-cache \
+))
+
+# vim: set noet sw=4 ts=4: