summaryrefslogtreecommitdiffstats
path: root/binaryurp/Library_binaryurp.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /binaryurp/Library_binaryurp.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'binaryurp/Library_binaryurp.mk')
-rw-r--r--binaryurp/Library_binaryurp.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/binaryurp/Library_binaryurp.mk b/binaryurp/Library_binaryurp.mk
new file mode 100644
index 000000000..439f1f7d4
--- /dev/null
+++ b/binaryurp/Library_binaryurp.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,binaryurp))
+
+$(eval $(call gb_Library_set_componentfile,binaryurp,binaryurp/source/binaryurp,ure/services))
+
+$(eval $(call gb_Library_use_udk_api,binaryurp))
+
+$(eval $(call gb_Library_use_external,binaryurp,boost_headers))
+
+$(eval $(call gb_Library_use_libraries,binaryurp,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,binaryurp,\
+ binaryurp/source/binaryany \
+ binaryurp/source/bridge \
+ binaryurp/source/bridgefactory \
+ binaryurp/source/currentcontext \
+ binaryurp/source/incomingrequest \
+ binaryurp/source/lessoperators \
+ binaryurp/source/marshal \
+ binaryurp/source/outgoingrequests \
+ binaryurp/source/proxy \
+ binaryurp/source/reader \
+ binaryurp/source/unmarshal \
+ binaryurp/source/writer \
+))
+
+# vim: set noet sw=4 ts=4: