summaryrefslogtreecommitdiffstats
path: root/bridges/Module_bridges.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /bridges/Module_bridges.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bridges/Module_bridges.mk')
-rw-r--r--bridges/Module_bridges.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/bridges/Module_bridges.mk b/bridges/Module_bridges.mk
new file mode 100644
index 000000000..3016bf2c4
--- /dev/null
+++ b/bridges/Module_bridges.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,bridges))
+
+$(eval $(call gb_Module_add_targets,bridges,\
+ Library_cpp_uno \
+ $(if $(ENABLE_JAVA),\
+ Jar_java_uno \
+ Library_java_uno \
+ $(if $(filter MACOSX,$(OS)),Package_jnilib_java_uno) \
+ ) \
+ $(if $(filter ARM,$(CPUNAME)),\
+ $(if $(filter ANDROID LINUX,$(OS)),\
+ CustomTarget_gcc3_linux_arm) \
+ ) \
+))
+
+ifeq (,$(filter build,$(gb_Module_SKIPTARGETS)))
+ifeq ($(strip $(bridges_SELECTED_BRIDGE)),)
+$(call gb_Output_error,no bridge selected for build: bailing out)
+else ifneq ($(words $(bridges_SELECTED_BRIDGE)),1)
+$(call gb_Output_error,multiple bridges selected for build: $(bridges_SELECTED_BRIDGE))
+endif
+endif
+
+# vim: set noet sw=4 ts=4: