summaryrefslogtreecommitdiffstats
path: root/canvas/Library_cairocanvas.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /canvas/Library_cairocanvas.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'canvas/Library_cairocanvas.mk')
-rw-r--r--canvas/Library_cairocanvas.mk75
1 files changed, 75 insertions, 0 deletions
diff --git a/canvas/Library_cairocanvas.mk b/canvas/Library_cairocanvas.mk
new file mode 100644
index 000000000..b7cd8d86b
--- /dev/null
+++ b/canvas/Library_cairocanvas.mk
@@ -0,0 +1,75 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,cairocanvas))
+
+$(eval $(call gb_Library_set_include,cairocanvas,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/canvas/inc \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,cairocanvas,canvas/inc/pch/precompiled_cairocanvas))
+
+$(eval $(call gb_Library_set_componentfile,cairocanvas,canvas/source/cairo/cairocanvas,services))
+
+$(eval $(call gb_Library_use_sdk_api,cairocanvas))
+
+ifeq ($(OS),MACOSX)
+
+$(eval $(call gb_Library_use_system_darwin_frameworks,cairocanvas,\
+ Cocoa \
+))
+
+endif
+
+$(eval $(call gb_Library_use_libraries,cairocanvas,\
+ sal \
+ cppu \
+ basegfx \
+ cppuhelper \
+ comphelper \
+ vcl \
+ tk \
+ tl \
+ i18nlangtag \
+ canvastools \
+))
+
+$(eval $(call gb_Library_add_exception_objects,cairocanvas,\
+ canvas/source/cairo/cairo_cachedbitmap \
+ canvas/source/cairo/cairo_canvas \
+ canvas/source/cairo/cairo_canvasbitmap \
+ canvas/source/cairo/cairo_canvascustomsprite \
+ canvas/source/cairo/cairo_canvasfont \
+ canvas/source/cairo/cairo_canvashelper \
+ canvas/source/cairo/cairo_canvashelper_text \
+ canvas/source/cairo/cairo_devicehelper \
+ canvas/source/cairo/cairo_spritecanvas \
+ canvas/source/cairo/cairo_spritecanvashelper \
+ canvas/source/cairo/cairo_spritedevicehelper \
+ canvas/source/cairo/cairo_spritehelper \
+ canvas/source/cairo/cairo_textlayout \
+))
+
+$(eval $(call gb_Library_use_externals,cairocanvas,\
+ boost_headers \
+ cairo \
+))
+
+# vim: set noet sw=4 ts=4: