summaryrefslogtreecommitdiffstats
path: root/canvas/Library_canvastools.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /canvas/Library_canvastools.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'canvas/Library_canvastools.mk')
-rw-r--r--canvas/Library_canvastools.mk79
1 files changed, 79 insertions, 0 deletions
diff --git a/canvas/Library_canvastools.mk b/canvas/Library_canvastools.mk
new file mode 100644
index 000000000..f810cab5c
--- /dev/null
+++ b/canvas/Library_canvastools.mk
@@ -0,0 +1,79 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,canvastools))
+
+$(eval $(call gb_Library_set_include,canvastools,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/canvas/inc \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,canvastools,canvas/inc/pch/precompiled_canvastools))
+
+$(eval $(call gb_Library_use_sdk_api,canvastools))
+
+$(eval $(call gb_Library_add_defs,canvastools,\
+ -DCANVASTOOLS_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_external,canvastools,boost_headers))
+
+$(eval $(call gb_Library_use_libraries,canvastools,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tk \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,canvastools,\
+ canvas/source/tools/cachedprimitivebase \
+ canvas/source/tools/canvascustomspritehelper \
+ canvas/source/tools/canvastools \
+ canvas/source/tools/elapsedtime \
+ canvas/source/tools/page \
+ canvas/source/tools/pagemanager \
+ canvas/source/tools/parametricpolypolygon \
+ canvas/source/tools/propertysethelper \
+ canvas/source/tools/spriteredrawmanager \
+ canvas/source/tools/surface \
+ canvas/source/tools/surfaceproxy \
+ canvas/source/tools/surfaceproxymanager \
+ canvas/source/tools/verifyinput \
+))
+
+ifeq ($(strip $(ENABLE_AGG)),YES)
+$(eval $(call gb_Library_add_exception_objects,canvastools,\
+ canvas/source/tools/bitmap \
+ canvas/source/tools/image \
+))
+$(eval $(call gb_Library_use_libraries,canvastools,\
+ agg \
+))
+ifneq ($(strip $(AGG_VERSION)),)
+$(eval $(call gb_Library_add_defs,canvastools,\
+ -DAGG_VERSION=$(AGG_VERSION) \
+))
+endif
+endif
+
+# vim: set noet sw=4 ts=4: