summaryrefslogtreecommitdiffstats
path: root/cli_ure/Executable_climaker.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /cli_ure/Executable_climaker.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cli_ure/Executable_climaker.mk')
-rw-r--r--cli_ure/Executable_climaker.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/cli_ure/Executable_climaker.mk b/cli_ure/Executable_climaker.mk
new file mode 100644
index 000000000..f0769b627
--- /dev/null
+++ b/cli_ure/Executable_climaker.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,climaker))
+
+$(eval $(call gb_Executable_use_package,climaker,\
+ cli_basetypes_copy \
+))
+
+$(eval $(call gb_Executable_add_cxxclrflags,climaker,\
+ -LN \
+ -wd4715 \
+))
+
+$(eval $(call gb_Executable_add_ldflags,climaker,\
+ -ignore:4248 \
+))
+
+$(eval $(call gb_Executable_use_internal_bootstrap_api,climaker,\
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_libraries,climaker,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ unoidl \
+))
+
+$(eval $(call gb_Executable_use_system_win32_libs,climaker,\
+ mscoree \
+ msvcmrt \
+))
+
+$(eval $(call gb_Executable_add_cxxclrobjects,climaker,\
+ cli_ure/source/climaker/climaker_app \
+ cli_ure/source/climaker/climaker_emit \
+))
+
+$(call gb_Executable_get_headers_target,climaker) : \
+ $(call gb_CliLibrary_get_target,cli_basetypes)
+
+# vim: set noet sw=4 ts=4: