summaryrefslogtreecommitdiffstats
path: root/codemaker/StaticLibrary_codemaker_java.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /codemaker/StaticLibrary_codemaker_java.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'codemaker/StaticLibrary_codemaker_java.mk')
-rw-r--r--codemaker/StaticLibrary_codemaker_java.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/codemaker/StaticLibrary_codemaker_java.mk b/codemaker/StaticLibrary_codemaker_java.mk
new file mode 100644
index 000000000..42343a621
--- /dev/null
+++ b/codemaker/StaticLibrary_codemaker_java.mk
@@ -0,0 +1,19 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,codemaker_java))
+
+$(eval $(call gb_StaticLibrary_use_external,codemaker_java,boost_headers))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,codemaker_java,\
+ codemaker/source/commonjava/commonjava \
+))
+
+# vim: set noet sw=4 ts=4: