summaryrefslogtreecommitdiffstats
path: root/connectivity/Library_firebird_sdbc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /connectivity/Library_firebird_sdbc.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'connectivity/Library_firebird_sdbc.mk')
-rw-r--r--connectivity/Library_firebird_sdbc.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/connectivity/Library_firebird_sdbc.mk b/connectivity/Library_firebird_sdbc.mk
new file mode 100644
index 000000000..720dfeb87
--- /dev/null
+++ b/connectivity/Library_firebird_sdbc.mk
@@ -0,0 +1,68 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,firebird_sdbc))
+
+$(eval $(call gb_Library_use_sdk_api,firebird_sdbc))
+
+$(eval $(call gb_Library_use_externals,firebird_sdbc,\
+ boost_headers \
+ libfbembed \
+))
+
+$(eval $(call gb_Library_set_include,firebird_sdbc,\
+ -I$(SRCDIR)/connectivity/inc \
+ -I$(SRCDIR)/connectivity/source/inc \
+ $$(INCLUDE) \
+ -I$(WORKDIR)/YaccTarget/connectivity/source/parse \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,firebird_sdbc,connectivity/inc/pch/precompiled_firebird_sdbc))
+
+$(eval $(call gb_Library_use_libraries,firebird_sdbc, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ dbtools \
+ sal \
+ salhelper \
+ utl \
+ svt \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_set_componentfile,firebird_sdbc,connectivity/source/drivers/firebird/firebird_sdbc,services))
+
+$(eval $(call gb_Library_add_exception_objects,firebird_sdbc,\
+ connectivity/source/drivers/firebird/Blob \
+ connectivity/source/drivers/firebird/Clob \
+ connectivity/source/drivers/firebird/Catalog \
+ connectivity/source/drivers/firebird/Column \
+ connectivity/source/drivers/firebird/Columns \
+ connectivity/source/drivers/firebird/Connection \
+ connectivity/source/drivers/firebird/DatabaseMetaData \
+ connectivity/source/drivers/firebird/Driver \
+ connectivity/source/drivers/firebird/Indexes \
+ connectivity/source/drivers/firebird/Keys \
+ connectivity/source/drivers/firebird/PreparedStatement \
+ connectivity/source/drivers/firebird/ResultSet \
+ connectivity/source/drivers/firebird/ResultSetMetaData \
+ connectivity/source/drivers/firebird/Statement \
+ connectivity/source/drivers/firebird/StatementCommonBase \
+ connectivity/source/drivers/firebird/Table \
+ connectivity/source/drivers/firebird/Tables \
+ connectivity/source/drivers/firebird/User \
+ connectivity/source/drivers/firebird/Users \
+ connectivity/source/drivers/firebird/Util \
+ connectivity/source/drivers/firebird/View \
+ connectivity/source/drivers/firebird/Views \
+))
+
+# vim: set noet sw=4 ts=4: