summaryrefslogtreecommitdiffstats
path: root/connectivity/Library_mysqlc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /connectivity/Library_mysqlc.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'connectivity/Library_mysqlc.mk')
-rw-r--r--connectivity/Library_mysqlc.mk77
1 files changed, 77 insertions, 0 deletions
diff --git a/connectivity/Library_mysqlc.mk b/connectivity/Library_mysqlc.mk
new file mode 100644
index 000000000..afc8f19b8
--- /dev/null
+++ b/connectivity/Library_mysqlc.mk
@@ -0,0 +1,77 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, you can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,mysqlc))
+
+$(eval $(call gb_Library_use_externals,mysqlc,\
+ boost_headers \
+ mariadb-connector-c \
+ openssl \
+))
+
+$(eval $(call gb_Library_set_include,mysqlc,\
+ -I$(SRCDIR)/connectivity/inc \
+ -I$(SRCDIR)/connectivity/source/inc \
+ $$(INCLUDE) \
+ -I$(WORKDIR)/YaccTarget/connectivity/source/parse \
+))
+
+$(eval $(call gb_Library_add_libs,mysqlc,\
+ $(if $(filter-out WNT,$(OS)),$(if $(filter HAIKU MACOSX SOLARIS,$(OS)),\
+ -lz -lm,-rdynamic -lz -lcrypt -lm)) \
+ $(if $(filter LINUX,$(OS)),-ldl,) \
+))
+
+$(eval $(call gb_Library_use_sdk_api,mysqlc))
+
+$(eval $(call gb_Library_use_libraries,mysqlc,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ dbtools \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_defs,mysqlc,\
+ -DCPPDBC_EXPORTS \
+ -DCPPCONN_LIB_BUILD \
+ -DMARIADBC_VERSION_MAJOR=$(MARIADBC_MAJOR) \
+ -DMARIADBC_VERSION_MINOR=$(MARIADBC_MINOR) \
+ -DMARIADBC_VERSION_MICRO=$(MARIADBC_MICRO) \
+ $(if $(BUNDLE_MARIADB_CONNECTOR_C),-DBUNDLE_MARIADB=\"$(LIBMARIADB)\") \
+))
+
+$(eval $(call gb_Library_add_exception_objects,mysqlc,\
+ connectivity/source/drivers/mysqlc/mysqlc_catalog \
+ connectivity/source/drivers/mysqlc/mysqlc_column \
+ connectivity/source/drivers/mysqlc/mysqlc_columns \
+ connectivity/source/drivers/mysqlc/mysqlc_connection \
+ connectivity/source/drivers/mysqlc/mysqlc_databasemetadata \
+ connectivity/source/drivers/mysqlc/mysqlc_driver \
+ connectivity/source/drivers/mysqlc/mysqlc_general \
+ connectivity/source/drivers/mysqlc/mysqlc_indexes \
+ connectivity/source/drivers/mysqlc/mysqlc_keys \
+ connectivity/source/drivers/mysqlc/mysqlc_prepared_resultset \
+ connectivity/source/drivers/mysqlc/mysqlc_preparedstatement \
+ connectivity/source/drivers/mysqlc/mysqlc_resultset \
+ connectivity/source/drivers/mysqlc/mysqlc_resultsetmetadata \
+ connectivity/source/drivers/mysqlc/mysqlc_services \
+ connectivity/source/drivers/mysqlc/mysqlc_statement \
+ connectivity/source/drivers/mysqlc/mysqlc_table \
+ connectivity/source/drivers/mysqlc/mysqlc_tables \
+ connectivity/source/drivers/mysqlc/mysqlc_types \
+ connectivity/source/drivers/mysqlc/mysqlc_user \
+ connectivity/source/drivers/mysqlc/mysqlc_view \
+ connectivity/source/drivers/mysqlc/mysqlc_views \
+))
+
+$(eval $(call gb_Library_set_componentfile,mysqlc,connectivity/source/drivers/mysqlc/mysqlc,services))
+
+# vim: set noet sw=4 ts=4: