summaryrefslogtreecommitdiffstats
path: root/connectivity/Library_postgresql-sdbc-impl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /connectivity/Library_postgresql-sdbc-impl.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'connectivity/Library_postgresql-sdbc-impl.mk')
-rw-r--r--connectivity/Library_postgresql-sdbc-impl.mk108
1 files changed, 108 insertions, 0 deletions
diff --git a/connectivity/Library_postgresql-sdbc-impl.mk b/connectivity/Library_postgresql-sdbc-impl.mk
new file mode 100644
index 000000000..497f5b742
--- /dev/null
+++ b/connectivity/Library_postgresql-sdbc-impl.mk
@@ -0,0 +1,108 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,postgresql-sdbc-impl))
+
+$(eval $(call gb_Library_add_defs,postgresql-sdbc-impl,\
+ -DPQ_SDBC_MAJOR=0 \
+ -DPQ_SDBC_MINOR=8 \
+ -DPQ_SDBC_MICRO=2 \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,postgresql-sdbc-impl,connectivity/inc/pch/precompiled_postgresql-sdbc-impl))
+
+$(eval $(call gb_Library_use_sdk_api,postgresql-sdbc-impl))
+
+$(eval $(call gb_Library_use_libraries,postgresql-sdbc-impl,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ dbtools \
+ sal \
+ salhelper \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Library_use_system_win32_libs,postgresql-sdbc-impl,\
+ shell32 \
+ wldap32 \
+))
+
+ifeq ($(COM),MSC)
+$(eval $(call gb_Library_add_ldflags,postgresql-sdbc-impl,\
+ /NODEFAULTLIB:libcmt.lib \
+))
+endif
+
+endif
+
+$(eval $(call gb_Library_use_externals,postgresql-sdbc-impl,\
+ boost_headers \
+ postgresql \
+ $(if $(filter-out MSC,$(COM)), \
+ $(if $(ENABLE_OPENSSL),openssl) \
+ $(if $(ENABLE_LDAP), \
+ openldap \
+ nss3 \
+ plc4 \
+ ssl3 \
+ ) \
+ ) \
+))
+
+ifeq ($(SYSTEM_POSTGRESQL),)
+ifneq ($(OS),WNT)
+
+$(eval $(call gb_Library_add_libs,postgresql-sdbc-impl,\
+ $(if $(WITH_GSSAPI),$(GSSAPI_LIBS)) \
+ $(if $(WITH_KRB5),$(KRB5_LIBS)) \
+ $(if $(filter-out MACOSX,$(OS)),-ldl) \
+))
+
+endif
+endif
+
+$(eval $(call gb_Library_set_componentfile,postgresql-sdbc-impl,connectivity/source/drivers/postgresql/postgresql-sdbc-impl,postgresql-sdbc))
+
+$(eval $(call gb_Library_add_exception_objects,postgresql-sdbc-impl,\
+ connectivity/source/drivers/postgresql/pq_array \
+ connectivity/source/drivers/postgresql/pq_baseresultset \
+ connectivity/source/drivers/postgresql/pq_connection \
+ connectivity/source/drivers/postgresql/pq_databasemetadata \
+ connectivity/source/drivers/postgresql/pq_fakedupdateableresultset \
+ connectivity/source/drivers/postgresql/pq_preparedstatement \
+ connectivity/source/drivers/postgresql/pq_resultset \
+ connectivity/source/drivers/postgresql/pq_resultsetmetadata \
+ connectivity/source/drivers/postgresql/pq_sequenceresultset \
+ connectivity/source/drivers/postgresql/pq_sequenceresultsetmetadata \
+ connectivity/source/drivers/postgresql/pq_statement \
+ connectivity/source/drivers/postgresql/pq_statics \
+ connectivity/source/drivers/postgresql/pq_tools \
+ connectivity/source/drivers/postgresql/pq_updateableresultset \
+ connectivity/source/drivers/postgresql/pq_xbase \
+ connectivity/source/drivers/postgresql/pq_xcolumn \
+ connectivity/source/drivers/postgresql/pq_xcolumns \
+ connectivity/source/drivers/postgresql/pq_xcontainer \
+ connectivity/source/drivers/postgresql/pq_xindex \
+ connectivity/source/drivers/postgresql/pq_xindexcolumn \
+ connectivity/source/drivers/postgresql/pq_xindexcolumns \
+ connectivity/source/drivers/postgresql/pq_xindexes \
+ connectivity/source/drivers/postgresql/pq_xkey \
+ connectivity/source/drivers/postgresql/pq_xkeycolumn \
+ connectivity/source/drivers/postgresql/pq_xkeycolumns \
+ connectivity/source/drivers/postgresql/pq_xkeys \
+ connectivity/source/drivers/postgresql/pq_xtable \
+ connectivity/source/drivers/postgresql/pq_xtables \
+ connectivity/source/drivers/postgresql/pq_xuser \
+ connectivity/source/drivers/postgresql/pq_xusers \
+ connectivity/source/drivers/postgresql/pq_xview \
+ connectivity/source/drivers/postgresql/pq_xviews \
+))
+
+# vim: set noet sw=4 ts=4: