summaryrefslogtreecommitdiffstats
path: root/cppu/CppunitTest_cppu_typelib.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /cppu/CppunitTest_cppu_typelib.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cppu/CppunitTest_cppu_typelib.mk')
-rw-r--r--cppu/CppunitTest_cppu_typelib.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/cppu/CppunitTest_cppu_typelib.mk b/cppu/CppunitTest_cppu_typelib.mk
new file mode 100644
index 000000000..ba9236f61
--- /dev/null
+++ b/cppu/CppunitTest_cppu_typelib.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,cppu_typelib))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,cppu_typelib, \
+ cppu/qa/typelib \
+))
+
+$(eval $(call gb_CppunitTest_use_api,cppu_typelib, \
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,cppu_typelib, \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,cppu_typelib))
+
+# vim: set noet sw=4 ts=4: