summaryrefslogtreecommitdiffstats
path: root/desktop/Library_crashextension.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /desktop/Library_crashextension.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Library_crashextension.mk')
-rw-r--r--desktop/Library_crashextension.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/desktop/Library_crashextension.mk b/desktop/Library_crashextension.mk
new file mode 100644
index 000000000..ae1841268
--- /dev/null
+++ b/desktop/Library_crashextension.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,crashextension))
+
+$(eval $(call gb_Library_add_exception_objects,crashextension, \
+ desktop/test/deployment/crashextension/crashextension \
+))
+
+$(eval $(call gb_Library_set_componentfile,crashextension,desktop/test/deployment/crashextension/crashextension,crashextension))
+
+$(eval $(call gb_Library_set_external_code,crashextension))
+
+$(eval $(call gb_Library_use_libraries,crashextension, \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_use_sdk_api,crashextension))
+
+# vim: set noet sw=4 ts=4: