summaryrefslogtreecommitdiffstats
path: root/editeng/Module_editeng.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /editeng/Module_editeng.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'editeng/Module_editeng.mk')
-rw-r--r--editeng/Module_editeng.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/editeng/Module_editeng.mk b/editeng/Module_editeng.mk
new file mode 100644
index 000000000..6fedbcb60
--- /dev/null
+++ b/editeng/Module_editeng.mk
@@ -0,0 +1,39 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,editeng))
+
+$(eval $(call gb_Module_add_targets,editeng,\
+ CustomTarget_generated \
+ Library_editeng \
+ UIConfig_editeng \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,editeng,\
+ AllLangMoTarget_editeng \
+))
+
+$(eval $(call gb_Module_add_check_targets,editeng,\
+ $(if $(and $(filter $(COM),MSC),$(MERGELIBS)),, \
+ CppunitTest_editeng_core) \
+ CppunitTest_editeng_borderline \
+ CppunitTest_editeng_lookuptree \
+))
+
+# vim: set noet sw=4 ts=4: