summaryrefslogtreecommitdiffstats
path: root/embeddedobj/test/Container1/makefile.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /embeddedobj/test/Container1/makefile.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'embeddedobj/test/Container1/makefile.mk')
-rw-r--r--embeddedobj/test/Container1/makefile.mk78
1 files changed, 78 insertions, 0 deletions
diff --git a/embeddedobj/test/Container1/makefile.mk b/embeddedobj/test/Container1/makefile.mk
new file mode 100644
index 000000000..f2523cae5
--- /dev/null
+++ b/embeddedobj/test/Container1/makefile.mk
@@ -0,0 +1,78 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ = ..$/..
+TARGET = EmbedContFrame
+PRJNAME = embeddedobj
+PACKAGE = embeddedobj$/test
+
+# --- Settings -----------------------------------------------------
+.INCLUDE: settings.mk
+
+# EXEC_CLASSPATH_TMP = \
+# $(foreach,i,$(JARFILES) $(SOLARBINDIR)$/$i)$(LIBO_PATH_SEPARATOR)
+# EXEC_CLASSPATH = \
+# $(strip $(subst,!,$(LIBO_PATH_SEPARATOR) $(EXEC_CLASSPATH_TMP:s/ /!/)))
+
+#----- compile .java files -----------------------------------------
+
+JARFILES = ridl.jar unoil.jar jurt.jar juh.jar java_uno.jar
+
+JAVAFILES = \
+ EmbedContApp.java\
+ EmbedContFrame.java\
+ NativeView.java\
+ WindowHelper.java\
+ JavaWindowPeerFake.java\
+ BitmapPainter.java\
+ PaintThread.java
+
+CLASSFILES = $(patsubst %.java,$(OUT_COMP_CLASS)/%.class,$(JAVAFILES))
+
+
+# --- Targets ------------------------------------------------------
+
+.INCLUDE: target.mk
+
+ALL : $(OUT)$/slo$/nativeview.obj
+ JavaStorageTestExample
+
+JavaStorageTestExample : $(CLASSFILES)
+ @echo --------------------------------------------------------------------------------
+ @echo "Please use following command to execute the example!"
+ @echo ------
+ @echo "dmake run"
+ @echo --------------------------------------------------------------------------------
+
+# $(OUT)$/slo$/nativeview.obj:
+ # cd nativelib; dmake debug=t; cd ..
+
+# echo $(SOLARBINDIR)
+# echo $(EXEC_CLASSPATH)
+
+run: $(CLASSFILES)
+ +set PATH=$(PATH)$(LIBO_PATH_SEPARATOR)$(JDK14PATH)$/jre$/bin && \
+ java -classpath "$(OUT)$/class;$(OUT)$/lib;$(OUT)$/bin;$(JDK14PATH)$/jre$/bin;$(JDK14PATH)$/jre$/lib;$(CLASSPATH)" embeddedobj.test.EmbedContFrame
+
+debug: $(CLASSFILES)
+ +set PATH=$(PATH)$(LIBO_PATH_SEPARATOR)$(JDK14PATH)$/jre$/bin && \
+ jdb -classpath "$(OUT)$/class;$(OUT)$/lib;$(OUT)$/bin;$(CLASSPATH)" embeddedobj.test.EmbedContFrame
+
+clean :
+ -$(DELRECURSIVE) $(subst /,$(PS),$(OUT_COMP_CLASS))
+