summaryrefslogtreecommitdiffstats
path: root/embeddedobj/test/Container1/nativelib/makefile.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /embeddedobj/test/Container1/nativelib/makefile.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'embeddedobj/test/Container1/nativelib/makefile.mk')
-rw-r--r--embeddedobj/test/Container1/nativelib/makefile.mk69
1 files changed, 69 insertions, 0 deletions
diff --git a/embeddedobj/test/Container1/nativelib/makefile.mk b/embeddedobj/test/Container1/nativelib/makefile.mk
new file mode 100644
index 000000000..771b12bf4
--- /dev/null
+++ b/embeddedobj/test/Container1/nativelib/makefile.mk
@@ -0,0 +1,69 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ=..$/..$/..
+PRJNAME=embeddedobj
+TARGET=nativeview
+# LIBTARGET=NO
+USE_DEFFILE=TRUE
+ENABLE_EXCEPTIONS=TRUE
+VERSIONOBJ=
+PACKAGE=embeddedobj$/test
+
+USE_JAVAVER:=TRUE
+
+# --- Settings -----------------------------------------------------
+
+.INCLUDE : settings.mk
+
+# --- Files --------------------------------------------------------
+
+.IF "$(JAVANUMVER:s/.//)" >= "000100040000"
+
+SLOFILES= $(SLO)$/nativeview.obj
+
+SHL1TARGET=$(TARGET)
+SHL1IMPLIB=i$(SHL1TARGET)
+
+SHL1STDLIBS= \
+ jawt.lib
+
+SHL1OBJS=$(SLOFILES)
+SHL1VERSIONOBJ=
+
+DEF1NAME=$(SHL1TARGET)
+DEF1EXPORTFILE=exports.dxp
+
+SHL1HEADER=nativeview.h
+
+.ENDIF # "$(JAVANUMVER:s/.//)" >= "000100040000"
+
+# --- Targets ------------------------------------------------------
+
+.INCLUDE : target.mk
+
+.IF "$(JAVANUMVER:s/.//)" >= "000100040000"
+
+$(SLO)$/nativeview.obj : $(SHL1HEADER)
+
+$(SHL1HEADER) :
+ javah -classpath $(OUT)$/class -o $(SHL1HEADER) embeddedobj.test
+
+.ENDIF # "$(JAVANUMVER:s/.//)" >= "000100040000"
+
+