summaryrefslogtreecommitdiffstats
path: root/eventattacher/Library_evtatt.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /eventattacher/Library_evtatt.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'eventattacher/Library_evtatt.mk')
-rw-r--r--eventattacher/Library_evtatt.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/eventattacher/Library_evtatt.mk b/eventattacher/Library_evtatt.mk
new file mode 100644
index 000000000..969c2b4b7
--- /dev/null
+++ b/eventattacher/Library_evtatt.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,evtatt))
+
+$(eval $(call gb_Library_set_componentfile,evtatt,eventattacher/source/evtatt,services))
+
+$(eval $(call gb_Library_use_libraries,evtatt,\
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,evtatt,\
+ eventattacher/source/eventattacher \
+))
+
+$(eval $(call gb_Library_use_api,evtatt,\
+ udkapi \
+))
+
+# vim: set ts=4 sw=4 et: