summaryrefslogtreecommitdiffstats
path: root/extensions/Library_dbp.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /extensions/Library_dbp.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_dbp.mk')
-rw-r--r--extensions/Library_dbp.mk55
1 files changed, 55 insertions, 0 deletions
diff --git a/extensions/Library_dbp.mk b/extensions/Library_dbp.mk
new file mode 100644
index 000000000..ec5f75c12
--- /dev/null
+++ b/extensions/Library_dbp.mk
@@ -0,0 +1,55 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,dbp))
+
+$(eval $(call gb_Library_set_componentfile,dbp,extensions/source/dbpilots/dbp,services))
+
+$(eval $(call gb_Library_set_include,dbp,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/extensions/inc \
+ -I$(SRCDIR)/extensions/source/inc \
+))
+
+$(eval $(call gb_Library_use_external,dbp,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,dbp))
+
+$(eval $(call gb_Library_add_exception_objects,dbp,\
+ extensions/source/dbpilots/commonpagesdbp \
+ extensions/source/dbpilots/controlwizard \
+ extensions/source/dbpilots/dbptools \
+ extensions/source/dbpilots/gridwizard \
+ extensions/source/dbpilots/groupboxwiz \
+ extensions/source/dbpilots/listcombowizard \
+ extensions/source/dbpilots/moduledbp \
+ extensions/source/dbpilots/optiongrouplayouter \
+ extensions/source/dbpilots/wizardservices \
+))
+
+$(eval $(call gb_Library_use_libraries,dbp,\
+ svt \
+ vcl \
+ tl \
+ tk \
+ svl \
+ sfx \
+ dbtools \
+ utl \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ salhelper \
+ i18nlangtag \
+))
+
+# vim:set noet sw=4 ts=4: