summaryrefslogtreecommitdiffstats
path: root/extensions/test/ole/cppToUno
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /extensions/test/ole/cppToUno
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/test/ole/cppToUno')
-rw-r--r--extensions/test/ole/cppToUno/makefile.mk56
-rw-r--r--extensions/test/ole/cppToUno/readme.txt8
-rw-r--r--extensions/test/ole/cppToUno/testcppuno.cxx206
3 files changed, 270 insertions, 0 deletions
diff --git a/extensions/test/ole/cppToUno/makefile.mk b/extensions/test/ole/cppToUno/makefile.mk
new file mode 100644
index 000000000..e40aa94f3
--- /dev/null
+++ b/extensions/test/ole/cppToUno/makefile.mk
@@ -0,0 +1,56 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ=..$/..$/..
+
+PRJNAME=extensions
+TARGET=testcppuno
+TARGETTYPE=CUI
+LIBTARGET=NO
+
+ENABLE_EXCEPTIONS=TRUE
+
+# --- Settings ---
+
+.INCLUDE : settings.mk
+
+# --- Files ---
+
+INCPRE+=-I$(ATL_INCLUDE)
+
+
+
+APP1TARGET= $(TARGET)
+APP1OBJS= $(OBJ)$/testcppuno.obj
+
+APP1STDLIBS= \
+ $(SALLIB) \
+ $(CPPUHELPERLIB) \
+ $(CPPULIB) \
+ $(USER32LIB) \
+ $(KERNEL32LIB) \
+ $(OLE32LIB) \
+ $(OLEAUT32LIB) \
+ $(UUIDLIB) \
+ $(COMDLG32LIB) \
+ $(GDI32LIB)
+
+APP1DEF= $(MISC)$/$(APP1TARGET).def
+
+# --- Targets ---
+.INCLUDE : target.mk
diff --git a/extensions/test/ole/cppToUno/readme.txt b/extensions/test/ole/cppToUno/readme.txt
new file mode 100644
index 000000000..ae0189818
--- /dev/null
+++ b/extensions/test/ole/cppToUno/readme.txt
@@ -0,0 +1,8 @@
+testcppuno.exe currently tests the conversion of SAFEARRAYs. There is
+no output from the program. Just step through the code.
+
+To run the test, the service oletest.OleTest ( extensions/test/ole/cpnt)
+must be in the same directory as the office dlls and it must be registered
+at the applicat.rdb. Also the type information must have been merged with
+applicat.rdb. The program requires an office to be present. Put testcppuno
+into the Office/program folder and run it there.
diff --git a/extensions/test/ole/cppToUno/testcppuno.cxx b/extensions/test/ole/cppToUno/testcppuno.cxx
new file mode 100644
index 000000000..e64541ed2
--- /dev/null
+++ b/extensions/test/ole/cppToUno/testcppuno.cxx
@@ -0,0 +1,206 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+
+#pragma warning(disable: 4917)
+#if !defined WIN32_LEAN_AND_MEAN
+# define WIN32_LEAN_AND_MEAN
+#endif
+#include <windows.h>
+#include <comdef.h>
+#include <atlbase.h>
+#include <atlcom.h>
+#include <stdio.h>
+#include <com/sun/star/bridge/ModelDependent.hpp>
+#include <com/sun/star/bridge/XBridgeSupplier2.hpp>
+#include <com/sun/star/lang/XMultiServiceFactory.hpp>
+#include <oletest/XCallback.hpp>
+#include <rtl/process.h>
+#include <cppuhelper/servicefactory.hxx>
+#include <rtl/string.h>
+
+
+using namespace com::sun::star::lang;
+using namespace com::sun::star::uno;
+using namespace com::sun::star::bridge;
+using namespace com::sun::star::bridge::ModelDependent;
+using namespace cppu;
+
+HRESULT doTest();
+bool incrementMultidimensionalIndex(
+ sal_Int32 dimensions,
+ const sal_Int32 * parDimensionLengths,
+ sal_Int32 * parMultidimensionalIndex);
+
+int SAL_CALL main( int /*argc*/, char** /*argv*/ )
+{
+ HRESULT hr;
+ if( FAILED( hr=CoInitializeEx(NULL, COINIT_APARTMENTTHREADED)))
+ {
+ printf("CoInitializeEx failed \n");
+ return -1;
+ }
+
+
+ if( FAILED(hr=doTest()))
+ {
+ _com_error err( hr);
+ const CHAR * errMsg= err.ErrorMessage();
+ MessageBoxA( NULL, errMsg, "Test failed", MB_ICONERROR);
+ }
+
+ CoUninitialize();
+ return 0;
+}
+
+
+HRESULT doTest()
+{
+ HRESULT hr= S_OK;
+ long j = 0;
+ SAFEARRAY* par;
+ CComDispatchDriver disp;
+ CComVariant result;
+ CComVariant param1;
+ CComPtr<IUnknown> spUnkFactory;
+ if( SUCCEEDED( spUnkFactory.CoCreateInstance(L"com.sun.star.ServiceManager")))
+ {
+ disp= spUnkFactory;
+ param1= L"oletest.OleTest";
+ disp.Invoke1( L"createInstance", &param1, &result);
+
+ disp= result.pdispVal;
+
+ // disp contains now oletest.OleTest
+
+ // one dimensional array
+ par= SafeArrayCreateVector( VT_UI1, 0, 5);
+ unsigned char arbyte[]= { 1,2,3,4,5};
+ for(long i= 0; i < 5;i++)
+ hr= SafeArrayPutElement( par, &i, &arbyte[i]);
+
+ result.Clear();
+ param1.vt= VT_ARRAY| VT_UI1;
+ param1.byref= par;
+ disp.Invoke1(L"methodByte", &param1, &result);
+ SafeArrayDestroy( par);
+
+
+ // two dimensional array
+ SAFEARRAYBOUND bounds[2];
+ // least significant dimension first, Dimension 1
+ bounds[0].cElements= 3;
+ bounds[0].lLbound= 0;
+ // Dimension 2
+ bounds[1].cElements= 2;
+ bounds[1].lLbound= 0;
+ par= SafeArrayCreate( VT_I4, 2, bounds );
+
+ long uBound1;
+ long uBound2;
+ hr= SafeArrayGetUBound( par, 1, &uBound1);
+ hr= SafeArrayGetUBound( par, 2, &uBound2);
+
+ long index2[2];
+ memset( index2, 0, 2 * sizeof( long) );
+ long dimLengths[]={3,2};
+
+ long data;
+ do
+ {
+ data= index2[1] * 3 + index2[0] +1;
+ hr= SafeArrayPutElement( par, index2, &data);
+ }while( incrementMultidimensionalIndex( 2, dimLengths, index2) );
+
+ long* pdata;
+ long (*dataL)[2][3];
+ hr= SafeArrayAccessData( par, (void**)&pdata);
+ dataL= (long(*)[2][3])pdata;
+
+ for (long i= 0; i < 2; i ++)
+ {
+ for(long j= 0; j < 3; j++)
+ data= (*dataL)[i][j];
+ }
+ hr= SafeArrayUnaccessData(par);
+
+ result.Clear();
+ param1.vt= VT_ARRAY | VT_I4;
+ param1.byref= par;
+ disp.Invoke1(L"methodSequence", &param1, &result);
+
+ SAFEARRAY* arRet= result.parray;
+
+ for(long i= 0; i < 2 ; i++)
+ {
+ CComVariant varx;
+ varx.Clear();
+ hr= SafeArrayGetElement( arRet, &i, &varx);
+ SAFEARRAY* ari= varx.parray;
+
+ for( j= 0; j < 3; j++)
+ {
+ CComVariant varj;
+ varj.Clear();
+ hr= SafeArrayGetElement( ari, &j, &varj);
+ }
+
+
+ }
+ SafeArrayDestroy( par);
+ }
+
+ return hr;
+}
+
+// left index is least significant
+bool incrementMultidimensionalIndex(
+ sal_Int32 dimensions,
+ const sal_Int32 * parDimensionLengths,
+ sal_Int32 * parMultidimensionalIndex)
+{
+ if( dimensions < 1)
+ return sal_False;
+
+ bool ret= sal_True;
+ bool carry= sal_True; // to get into the while loop
+
+ sal_Int32 currentDimension= 0; //most significant is 1
+ while( carry)
+ {
+ parMultidimensionalIndex[ currentDimension ]++;
+ // if carryover, set index to 0 and handle carry on a level above
+ if( parMultidimensionalIndex[ currentDimension] > (parDimensionLengths[ currentDimension] - 1))
+ parMultidimensionalIndex[ currentDimension]= 0;
+ else
+ carry= sal_False;
+
+ currentDimension ++;
+ // if dimensions drops below 1 and carry is set than then all indices are 0 again
+ // this is signalled by returning sal_False
+ if( currentDimension > dimensions - 1 && carry)
+ {
+ carry= sal_False;
+ ret= sal_False;
+ }
+ }
+ return ret;
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */