summaryrefslogtreecommitdiffstats
path: root/external/libzmf
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /external/libzmf
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'external/libzmf')
-rw-r--r--external/libzmf/ExternalProject_libzmf.mk49
-rw-r--r--external/libzmf/Makefile7
-rw-r--r--external/libzmf/Module_libzmf.mk17
-rw-r--r--external/libzmf/README4
-rw-r--r--external/libzmf/UnpackedTarball_libzmf.mk20
-rw-r--r--external/libzmf/android-workaround.patch.114
6 files changed, 111 insertions, 0 deletions
diff --git a/external/libzmf/ExternalProject_libzmf.mk b/external/libzmf/ExternalProject_libzmf.mk
new file mode 100644
index 000000000..1a338526c
--- /dev/null
+++ b/external/libzmf/ExternalProject_libzmf.mk
@@ -0,0 +1,49 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,libzmf))
+
+$(eval $(call gb_ExternalProject_use_autoconf,libzmf,build))
+
+$(eval $(call gb_ExternalProject_register_targets,libzmf,\
+ build \
+))
+
+$(eval $(call gb_ExternalProject_use_externals,libzmf,\
+ boost_headers \
+ icu \
+ libpng \
+ revenge \
+ zlib \
+))
+
+$(call gb_ExternalProject_get_state_target,libzmf,build) :
+ $(call gb_Trace_StartRange,libzmf,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ export PKG_CONFIG="" \
+ && MAKE=$(MAKE) $(gb_RUN_CONFIGURE) ./configure \
+ --with-pic \
+ --enable-static \
+ --disable-shared \
+ --without-docs \
+ --disable-tests \
+ --disable-tools \
+ --disable-debug \
+ --disable-werror \
+ --disable-weffc \
+ $(if $(verbose),--disable-silent-rules,--enable-silent-rules) \
+ CXXFLAGS="$(gb_CXXFLAGS) $(call gb_ExternalProject_get_build_flags,libzmf)" \
+ CPPFLAGS="$(CPPFLAGS) $(BOOST_CPPFLAGS)" \
+ LDFLAGS="$(call gb_ExternalProject_get_link_flags,libzmf)" \
+ $(gb_CONFIGURE_PLATFORMS) \
+ && $(MAKE) \
+ )
+ $(call gb_Trace_EndRange,libzmf,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libzmf/Makefile b/external/libzmf/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/libzmf/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libzmf/Module_libzmf.mk b/external/libzmf/Module_libzmf.mk
new file mode 100644
index 000000000..c024e697c
--- /dev/null
+++ b/external/libzmf/Module_libzmf.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,libzmf))
+
+$(eval $(call gb_Module_add_targets,libzmf,\
+ ExternalProject_libzmf \
+ UnpackedTarball_libzmf \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libzmf/README b/external/libzmf/README
new file mode 100644
index 000000000..ceb21ba87
--- /dev/null
+++ b/external/libzmf/README
@@ -0,0 +1,4 @@
+libzmf is a library and a set of tools for reading and converting
+Zoner Draw and Zebra file formats.
+
+[https://wiki.documentfoundation.org/DLP/Libraries/libzmf]
diff --git a/external/libzmf/UnpackedTarball_libzmf.mk b/external/libzmf/UnpackedTarball_libzmf.mk
new file mode 100644
index 000000000..d37e16fcb
--- /dev/null
+++ b/external/libzmf/UnpackedTarball_libzmf.mk
@@ -0,0 +1,20 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,libzmf))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,libzmf,$(ZMF_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,libzmf))
+
+$(eval $(call gb_UnpackedTarball_add_patches,libzmf, \
+ external/libzmf/android-workaround.patch.1 \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libzmf/android-workaround.patch.1 b/external/libzmf/android-workaround.patch.1
new file mode 100644
index 000000000..a46c5e8c3
--- /dev/null
+++ b/external/libzmf/android-workaround.patch.1
@@ -0,0 +1,14 @@
+--- libzmf.orig/src/lib/ZMFTypes.cpp 2017-09-17 12:14:41.987990622 +0100
++++ libzmf/src/lib/ZMFTypes.cpp 2017-09-17 12:16:32.636850391 +0100
+@@ -38,10 +38,9 @@
+
+ double Point::distance(const Point &p2) const
+ {
+- return std::hypot(p2.x - x, p2.y - y);
++ return ::hypot(p2.x - x, p2.y - y);
+ }
+
+-
+ BoundingBox::BoundingBox(const std::vector<Point> &points_)
+ : m_points(points_)
+ , m_width(0.0)