summaryrefslogtreecommitdiffstats
path: root/extras/Module_extras.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /extras/Module_extras.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extras/Module_extras.mk')
-rw-r--r--extras/Module_extras.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/extras/Module_extras.mk b/extras/Module_extras.mk
new file mode 100644
index 000000000..516209c5d
--- /dev/null
+++ b/extras/Module_extras.mk
@@ -0,0 +1,76 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,extras))
+
+$(eval $(call gb_Module_add_targets,extras,\
+ CustomTarget_autocorr \
+ CustomTarget_autotextuser \
+ CustomTarget_glade \
+ CustomTarget_gallsystem \
+ CustomTarget_tplofficorr \
+ CustomTarget_tploffimisc \
+ CustomTarget_tplpersonal \
+ CustomTarget_tplpresnt \
+ CustomTarget_tpl_styles \
+ CustomTarget_tpldraw \
+ Package_autocorr \
+ Package_autotextuser \
+ Package_cfgsrvnolang \
+ Package_cfgusr \
+ Package_database \
+ Package_databasebiblio \
+ Package_fonts \
+ Package_resource_fonts \
+ Package_gallbullets \
+ Package_gallmytheme \
+ Package_gallroot \
+ Package_gallsystem \
+ Package_gallsystemstr \
+ Package_glade \
+ Package_labels \
+ $(if $(filter WNT,$(OS)),Package_newfiles) \
+ Package_palettes \
+ Package_tplofficorr \
+ Package_tploffimisc \
+ Package_tplpersonal \
+ Package_tplpresnt \
+ Package_tpl_styles \
+ Package_tpldraw \
+ Package_tplwizagenda \
+ Package_tplwizbitmap \
+ Package_tplwizdesktop \
+ Package_tplwizfax \
+ Package_tplwizletter \
+ Package_tplwizreport \
+ Package_tplwizstyles \
+ Package_wordbook \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,extras,\
+ CustomTarget_autotextshare \
+ AllLangPackage_autotextshare \
+))
+
+ifneq ($(WITH_GALLERY_BUILD),)
+$(eval $(call gb_Module_add_targets,extras,\
+ Gallery_backgrounds \
+ $(call gb_Helper_optional,AVMEDIA,Gallery_sound) \
+))
+endif
+
+$(eval $(call gb_Module_add_targets,extras,\
+ Personas \
+))
+
+$(eval $(call gb_Module_add_targets,extras,\
+ CustomTarget_opensymbol \
+))
+
+# vim: set noet sw=4 ts=4: