summaryrefslogtreecommitdiffstats
path: root/fpicker/Library_fps.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /fpicker/Library_fps.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fpicker/Library_fps.mk')
-rw-r--r--fpicker/Library_fps.mk65
1 files changed, 65 insertions, 0 deletions
diff --git a/fpicker/Library_fps.mk b/fpicker/Library_fps.mk
new file mode 100644
index 000000000..3e14f03b7
--- /dev/null
+++ b/fpicker/Library_fps.mk
@@ -0,0 +1,65 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,fps))
+
+$(eval $(call gb_Library_use_custom_headers,fps,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_set_componentfile,fps,fpicker/source/win32/fps,services))
+
+$(eval $(call gb_Library_set_include,fps,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/fpicker/inc \
+))
+
+$(eval $(call gb_Library_use_external,fps,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,fps))
+
+$(eval $(call gb_Library_use_libraries,fps,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ i18nlangtag \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,fps,\
+ advapi32 \
+ comdlg32 \
+ gdi32 \
+ kernel32 \
+ ole32 \
+ oleaut32 \
+ shell32 \
+ uuid \
+))
+
+ifeq ($(COM),MSC)
+$(eval $(call gb_Library_add_libs,fps,\
+ Delayimp.lib /DELAYLOAD:shell32.dll \
+))
+endif
+
+$(eval $(call gb_Library_add_exception_objects,fps,\
+ fpicker/source/win32/FilterContainer \
+ fpicker/source/win32/VistaFilePicker \
+ fpicker/source/win32/VistaFilePickerEventHandler \
+ fpicker/source/win32/VistaFilePickerImpl \
+ fpicker/source/win32/resourceprovider \
+ fpicker/source/win32/WinImplHelper \
+))
+
+# vim: set noet sw=4 ts=4: