summaryrefslogtreecommitdiffstats
path: root/i18npool/CppunitTest_i18npool_textsearch.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /i18npool/CppunitTest_i18npool_textsearch.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'i18npool/CppunitTest_i18npool_textsearch.mk')
-rw-r--r--i18npool/CppunitTest_i18npool_textsearch.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/i18npool/CppunitTest_i18npool_textsearch.mk b/i18npool/CppunitTest_i18npool_textsearch.mk
new file mode 100644
index 000000000..e556abda2
--- /dev/null
+++ b/i18npool/CppunitTest_i18npool_textsearch.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,i18npool_textsearch))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,i18npool_textsearch))
+
+$(eval $(call gb_CppunitTest_use_ure,i18npool_textsearch))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,i18npool_textsearch,\
+ i18npool/qa/cppunit/test_textsearch \
+))
+
+$(eval $(call gb_CppunitTest_use_components,i18npool_textsearch,\
+ i18npool/source/search/i18nsearch \
+ i18npool/util/i18npool \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,i18npool_textsearch,\
+ icui18n \
+ icuuc \
+ icu_headers \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,i18npool_textsearch,\
+ cppu \
+ cppuhelper \
+ sal \
+ unotest \
+))
+
+# vim: set noet sw=4 ts=4: