summaryrefslogtreecommitdiffstats
path: root/i18nutil/Library_i18nutil.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /i18nutil/Library_i18nutil.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'i18nutil/Library_i18nutil.mk')
-rw-r--r--i18nutil/Library_i18nutil.mk55
1 files changed, 55 insertions, 0 deletions
diff --git a/i18nutil/Library_i18nutil.mk b/i18nutil/Library_i18nutil.mk
new file mode 100644
index 000000000..2a255e41d
--- /dev/null
+++ b/i18nutil/Library_i18nutil.mk
@@ -0,0 +1,55 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,i18nutil))
+
+$(eval $(call gb_Library_use_externals,i18nutil,\
+ boost_headers \
+ icu_headers \
+ icui18n \
+ icuuc \
+))
+
+$(eval $(call gb_Library_use_custom_headers,i18nutil,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_sdk_api,i18nutil))
+
+$(eval $(call gb_Library_add_defs,i18nutil,\
+ -DI18NUTIL_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_libraries,i18nutil,\
+ utl \
+ i18nlangtag \
+ comphelper \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,i18nutil,\
+ i18nutil/source/utility/casefolding \
+ i18nutil/source/utility/oneToOneMapping \
+ i18nutil/source/utility/paper \
+ i18nutil/source/utility/scripttypedetector \
+ i18nutil/source/utility/unicode \
+ i18nutil/source/utility/widthfolding \
+))
+
+# vim: set noet sw=4: