summaryrefslogtreecommitdiffstats
path: root/idlc/CustomTarget_parser_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /idlc/CustomTarget_parser_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'idlc/CustomTarget_parser_test.mk')
-rw-r--r--idlc/CustomTarget_parser_test.mk91
1 files changed, 91 insertions, 0 deletions
diff --git a/idlc/CustomTarget_parser_test.mk b/idlc/CustomTarget_parser_test.mk
new file mode 100644
index 000000000..f8c7632bd
--- /dev/null
+++ b/idlc/CustomTarget_parser_test.mk
@@ -0,0 +1,91 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,idlc/parser_test))
+
+# this target is phony to run it every time
+.PHONY : $(call gb_CustomTarget_get_target,idlc/parser_test)
+
+$(call gb_CustomTarget_get_target,idlc/parser_test) : \
+ $(call gb_Executable_get_runtime_dependencies,idlc) \
+ $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/attribute.tests \
+ $(SRCDIR)/idlc/test/parser/constant.tests \
+ $(SRCDIR)/idlc/test/parser/constructor.tests \
+ $(SRCDIR)/idlc/test/parser/conversion.tests \
+ $(SRCDIR)/idlc/test/parser/interfaceinheritance.tests \
+ $(SRCDIR)/idlc/test/parser/methodoverload.tests \
+ $(SRCDIR)/idlc/test/parser/polystruct.tests \
+ $(SRCDIR)/idlc/test/parser/published.tests \
+ $(SRCDIR)/idlc/test/parser/struct.tests \
+ $(SRCDIR)/idlc/test/parser/typedef.tests \
+ | $(call gb_CustomTarget_get_workdir,idlc/parser_test)/.dir
+ifneq ($(gb_SUPPRESS_TESTS),)
+ @true
+else
+ $(call gb_Helper_abbreviate_dirs,( \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/attribute.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/constant.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/constructor.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/conversion.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/interfaceinheritance.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/methodoverload.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/oldstyle.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/polystruct.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/published.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/struct.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {} && \
+ $(PERL) $(SRCDIR)/solenv/bin/exectest.pl \
+ $(SRCDIR)/idlc/test/parser/typedef.tests \
+ $(call gb_CustomTarget_get_workdir,idlc/parser_test)/in.idl 0 \
+ $(call gb_Executable_get_command,idlc) \
+ -O $(call gb_CustomTarget_get_workdir,idlc/parser_test) {}) \
+ > $@.log 2>&1 || (cat $@.log && false))
+endif
+
+# vim: set noet sw=4 ts=4: