summaryrefslogtreecommitdiffstats
path: root/javaunohelper/Library_juhx.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /javaunohelper/Library_juhx.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'javaunohelper/Library_juhx.mk')
-rw-r--r--javaunohelper/Library_juhx.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/javaunohelper/Library_juhx.mk b/javaunohelper/Library_juhx.mk
new file mode 100644
index 000000000..1a24e5ef5
--- /dev/null
+++ b/javaunohelper/Library_juhx.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,juhx))
+
+$(eval $(call gb_Library_use_internal_comprehensive_api,juhx,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,juhx,\
+ cppu \
+ cppuhelper \
+ jvmaccess \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,juhx,\
+ javaunohelper/source/bootstrap \
+ javaunohelper/source/javaunohelper \
+ javaunohelper/source/vm \
+))
+
+# vim:set noet sw=4 ts=4: