summaryrefslogtreecommitdiffstats
path: root/jurt/workbench
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /jurt/workbench
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'jurt/workbench')
-rw-r--r--jurt/workbench/com/sun/star/comp/urlresolver/UrlResolver_Test.java88
-rw-r--r--jurt/workbench/com/sun/star/comp/urlresolver/makefile.mk44
2 files changed, 132 insertions, 0 deletions
diff --git a/jurt/workbench/com/sun/star/comp/urlresolver/UrlResolver_Test.java b/jurt/workbench/com/sun/star/comp/urlresolver/UrlResolver_Test.java
new file mode 100644
index 000000000..09ebec87d
--- /dev/null
+++ b/jurt/workbench/com/sun/star/comp/urlresolver/UrlResolver_Test.java
@@ -0,0 +1,88 @@
+/* -*- Mode: Java; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+package com.sun.star.comp.urlresolver;
+
+import com.sun.star.uno.XComponentContext;
+import com.sun.star.comp.helper.Bootstrap;
+import com.sun.star.lang.XMultiComponentFactory;
+import com.sun.star.bridge.UnoUrlResolver;
+import com.sun.star.bridge.XUnoUrlResolver;
+import com.sun.star.beans.XPropertySet;
+import com.sun.star.uno.UnoRuntime;
+
+/** start the office with these options <br>
+ soffice --accept=socket,host=localhost,port=8100;urp;
+*/
+public class UrlResolver_Test
+{
+ public static void main(String[] args) {
+ try {
+ XComponentContext xcomponentcontext = Bootstrap.createInitialComponentContext( null );
+
+ // initial serviceManager
+ xcomponentcontext.getServiceManager();
+
+ // create a connector, so that it can contact the office
+ XUnoUrlResolver urlResolver
+ = UnoUrlResolver.create( xcomponentcontext );
+
+ Object initialObject = urlResolver.resolve(
+ "uno:socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" );
+
+ XMultiComponentFactory xOfficeFactory= UnoRuntime.queryInterface(
+ XMultiComponentFactory.class, initialObject );
+
+ // retrieve the component context (it's not yet exported from the office)
+ // Query for the XPropertySet interface.
+ XPropertySet xProperySet = UnoRuntime.queryInterface(
+ XPropertySet.class, xOfficeFactory);
+
+ // Get the default context from the office server.
+ Object oDefaultContext = xProperySet.getPropertyValue( "DefaultContext" );
+
+ // Query for the interface XComponentContext.
+ XComponentContext xOfficeComponentContext = UnoRuntime.queryInterface(
+ XComponentContext.class, oDefaultContext );
+
+ // now create the desktop service
+ // NOTE: use the office component context here !
+ xOfficeFactory.createInstanceWithContext("com.sun.star.frame.Desktop",
+ xOfficeComponentContext );
+ } catch(com.sun.star.connection.NoConnectException e) {
+ System.out.println(e.getMessage());
+ e.printStackTrace();
+ } catch(com.sun.star.connection.ConnectionSetupException ce) {
+ System.out.println(ce.getMessage());
+ ce.printStackTrace();
+ } catch(com.sun.star.lang.IllegalArgumentException ie) {
+ System.out.println(ie.getMessage());
+ ie.printStackTrace();
+ } catch(com.sun.star.beans.UnknownPropertyException ue) {
+ System.out.println(ue.getMessage());
+ ue.printStackTrace();
+ } catch(java.lang.Exception ee) {
+ System.out.println(ee.getMessage());
+ ee.printStackTrace();
+ }
+
+ }
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/jurt/workbench/com/sun/star/comp/urlresolver/makefile.mk b/jurt/workbench/com/sun/star/comp/urlresolver/makefile.mk
new file mode 100644
index 000000000..8bdbbd8cc
--- /dev/null
+++ b/jurt/workbench/com/sun/star/comp/urlresolver/makefile.mk
@@ -0,0 +1,44 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ := ..$/..$/..$/..$/..$/..
+PRJNAME := jurt
+TARGET := workbench_com_sun_star_comp_urlresolver
+
+PACKAGE := com$/sun$/star$/comp$/urlresolver
+JAVAFILES := UrlResolver_Test.java
+JARFILES := ridl.jar juh.jar
+
+.INCLUDE: settings.mk
+
+# Put the generated class files into <platform>/class/workbench/ instead of
+# <platform>/class/ (otherwise, these class files might end up being zipped into
+# the generated jurt.jar):
+.IF "$(XCLASSPATH)" == ""
+XCLASSPATH := $(CLASSDIR)
+.ELSE
+XCLASSPATH !:= $(XCLASSPATH)$(LIBO_PATH_SEPARATOR)$(CLASSDIR)
+.ENDIF
+CLASSDIR !:= $(CLASSDIR)$/workbench
+
+.INCLUDE: target.mk
+
+$(JAVAFILES): $(MISC)$/$(TARGET).createdclassdir
+$(MISC)$/$(TARGET).createdclassdir:
+ - $(MKDIR) $(CLASSDIR)
+ $(TOUCH) $@