summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Library_libreofficekitgtk.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /libreofficekit/Library_libreofficekitgtk.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'libreofficekit/Library_libreofficekitgtk.mk')
-rw-r--r--libreofficekit/Library_libreofficekitgtk.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/libreofficekit/Library_libreofficekitgtk.mk b/libreofficekit/Library_libreofficekitgtk.mk
new file mode 100644
index 000000000..9dedd0e64
--- /dev/null
+++ b/libreofficekit/Library_libreofficekitgtk.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,libreofficekitgtk))
+
+$(eval $(call gb_Library_use_sdk_api,libreofficekitgtk))
+
+$(eval $(call gb_Library_add_exception_objects,libreofficekitgtk,\
+ libreofficekit/source/gtk/lokdocview \
+ libreofficekit/source/gtk/tilebuffer \
+))
+
+$(eval $(call gb_Library_use_externals,libreofficekitgtk,\
+ boost_headers \
+))
+
+$(eval $(call gb_Library_set_include,libreofficekitgtk,\
+ $$(INCLUDE) \
+ $$(GTK3_CFLAGS) \
+))
+
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(GTK3_LIBS) \
+))
+
+$(eval $(call gb_Library_add_defs,libreofficekitgtk,\
+ -DLOK_PATH="\"$(LIBDIR)/libreoffice/$(LIBO_LIB_FOLDER)\"" \
+))
+
+ifeq ($(OS),$(filter LINUX %BSD SOLARIS, $(OS)))
+$(eval $(call gb_Library_add_libs,libreofficekitgtk,\
+ $(UNIX_DLAPI_LIBS) -lm \
+))
+endif
+
+# vim: set noet sw=4 ts=4: